Back to overview
Resolved

Compute provider deployment outage

Jul 20, 2026 at 7:00pm UTC
Affected services
cloud.strapi.io

Resolved
Jul 21, 2026 at 4:00am UTC

Service recovered without changes from our side.

Created
Jul 20, 2026 at 7:00pm UTC

Our compute provider experienced an outage that causes most new deployments to fail or time out. Existing deployments are not affected.