Back to overview
Degraded

Impossible to create project for US based users

Feb 16 at 07:43pm CET
Affected services
cloud.strapi.io

Resolved
Feb 16 at 08:12pm CET

The issue has been fixed.

Created
Feb 16 at 07:43pm CET

Due to an issue with our billing system, US based customers cannot create new projects.

We are actively working on fixing the issue.

Sorry for the inconvenience.