Back to overview
Resolved

Backups temporarily unavailable in the dashboard

Sep 3, 2026 at 12:16pm UTC
Affected services
cloud.strapi.io
API

Resolved
Sep 3, 2026 at 1:42pm UTC

Incident resolved, backups now appear as expected.

Created
Sep 3, 2026 at 12:16pm UTC

Backup related features are temporarily unavailable due to a backup provider issue. Your backups are safe and nothing has been deleted. We're working with the provider towards a resolution.